Mail delay issue
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Aug 07, 2018 - 16:26 CDT
Update
Unfortunately, we have discovered that some mail was returned to the sender during this incident for customers with short TTLs. Mail that was sent after a customer's TTL had expired may also have been returned to the sender, as well as mail from senders who had never sent to an AppRiver customer before, due to unresolved MX records. Some mail servers would have delivered a non-deliverable message back to the sender. In these cases mentioned, mail will need to be resent. We sincerely apologize for this inconvenience.
Posted Aug 07, 2018 - 14:25 CDT
Monitoring
We experienced a brief incident (approximately 20 minutes) where our ARSMTP zone was not reporting back IP addresses. This issue is now resolved and no mail was lost, however, this may have caused delays for a few senders when sending mail to AppRiver customers who had extremely short TTLs, or for senders who had never sent to an AppRiver customer before. We will continue to monitor the zone and apologize for any inconvenience.
Posted Aug 07, 2018 - 13:51 CDT
This incident affected: Encryption Services (EMP/DeliverySlip), Email Continuity (Secure Cloud Email Continuity), Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)), Threat Protection (Email Threat Protection), and Office 365, DNS Hosting.