HEX connection to OWA/Outlook

Incident Report for Zix | AppRiver

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 08:09 CST

Update

The should now be resolved.
Posted Feb 28, 2025 - 08:09 CST

Identified

We are getting reports that user mailboxes are successfully reconnecting. We are currently monitoring.
Posted Feb 27, 2025 - 16:23 CST

Investigating

Some users may experience issues connecting through Outlook and OWA for Hosted Exchange. Our engineering team is investigating and working to resolve the issue.
Posted Feb 27, 2025 - 16:10 CST
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).