EMEA OWA Login Issue
Incident Report for AppRiver
Resolved
This incident has been resolved.
Posted Oct 19, 2021 - 16:34 CDT
Monitoring
Our engineering team has put a fix in place to resolve the login issues. We are continuing to monitor the situation and apologize for the inconvenience.
Posted Oct 19, 2021 - 05:34 CDT
Investigating
We are currently investigating an issue with customers in our EMEA region experiencing login issues with OWA for our hosted exchange platform. We apologize for the inconvenience and appreciate your patience while we investigate the issue.
Posted Oct 19, 2021 - 04:29 CDT
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).