Exchange Online Service Alert users in role groups
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Nov 04, 2021 - 13:18 CDT
Monitoring
Exchange Online service alert

Advisory information
Title: Admins may be unable to view or manage users in role groups
ID: EX295761

Status
Service Restored

Details
Title: Admins may be unable to view or manage users in role groups

User Impact: Admins may have been unable to view or manage users in role groups.

More info: This issue was occurring in both the Security & Compliance Center (SCC) and PowerShell and was specific to groups that had an empty role group description. Admins may have received an error that includes "Error trying to set value..."

Final status: We've completed deployment of the fix to the affected infrastructure and after monitoring the service, we've confirmed that the fix has successfully remediated impact.

Scope of impact: This issue could have affected any admin attempting to add users to role groups with an empty role group description.

Start time: Thursday, October 28, 2021, at 1:00 AM UTC
End time: Thursday, November 4, 2021, at 7:00 AM UTC

Root cause: A recent code regression had led to admins being unable to view or manage users in role groups.

Next steps:
- We're investigating why the recent code regression had led to admins being unable to view or manage users in role groups to prevent this problem from happening again in the future.

This is the final update for the event.
Thank you,
The Microsoft team
Posted Nov 04, 2021 - 11:47 CDT
Investigating
Exchange Online service alert

Advisory information
Title: Admins may be unable to view or manage users in role groups
ID: EX295761

Status
Service Degradation

Details
Title: Admins may be unable to view or manage users in role groups

User Impact: Admins may be unable to view or manage users in role groups.

More info: This issue is occurring in both the Security & Compliance Center (SCC) and PowerShell and is specific to groups that have an empty role group description. Admins will receive an error that includes "Error trying to set value..."

Current status: We're reviewing authorization logs and are reproducing the issue in our internal environment to gain a better understanding of the root cause of the problem. Concurrently, we're reviewing any recent changes to see if these may have contributed to the issue.

Scope of impact: Impact is specific to some admins who are attempting to add users to role groups with an empty role group description.
Next update by: Tuesday, November 2, 2021, at 8:00 PM UTC

Thank you,
The Microsoft team
Posted Nov 02, 2021 - 15:03 CDT
This incident affected: Office 365.