Filtering for Invalid Address issue
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Dec 02, 2020 - 16:28 CST
Monitoring
The mail queue rescan was completed and released any valid mail that was held erroneously. We understand the importance of timely mail flow and sincerely apologize for any inconveniences this may have caused. We will continue to monitor performance throughout the day,
Posted Dec 02, 2020 - 07:25 CST
Update
Our team continues to monitor and test the the actions put in place to correct this issue. They expect to begin a process of starting a re-scan for messages that may have been held erroneously to release valid mail.
Posted Dec 01, 2020 - 14:27 CST
Identified
We are continuing to monitor actions our development and engineering team have put in place to correct issues with mail flow. Once testing has been completed the previously mentioned re-scan of messages that may have been held erroneously will take place. We appreciate your patience and will update again in 2 hours.
Posted Dec 01, 2020 - 11:09 CST
Investigating
Our Development and Engineering teams have identified a mail flow issue for some customers. Corrective action has been taken and they are currently verifying that it has resolved the issue.

Once verified, we will run a re-scan of messages - this will allow messages erroneously shown as deleted or held to be delivered from the past 3 days.
Posted Dec 01, 2020 - 10:19 CST
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)) and Threat Protection (Email Threat Protection).