Customer Portal Access
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Feb 16, 2021 - 07:23 CST
Monitoring
The slowness issue some customers were seeing earlier logging into the customer portal should be resolved. Our team will continue to monitor performance throughout the day though. We thank you for your patience and apologize for any inconvenience this may have caused.
Posted Feb 11, 2021 - 13:23 CST
Identified
Our development and engineering teams are continuing to investigate the issue. We apologize for any inconvenience this may be causing and will provide updates as they become available.
Posted Feb 11, 2021 - 12:40 CST
Update
We are continuing to investigate this issue.
Posted Feb 11, 2021 - 11:16 CST
Investigating
We are receiving reports of intermittent latency and access issues with the Customer Portal. Our teams are currently investigating.
Posted Feb 11, 2021 - 11:16 CST
This incident affected: Customer Portal Interface (Customer Portal).