Email Encryption Access Limited
Incident Report for Zix | AppRiver
Resolved
Email Encryption access has been fully restored for all customers.
Posted Jul 10, 2019 - 09:23 CDT
Investigating
We are investigating reports that certain customers are unable to access the Email Encryption (DeliverySlip) service online web portal. More information to come.
Posted Jul 10, 2019 - 08:31 CDT
This incident affected: Encryption Services (EMP/DeliverySlip).