Email delivery issue to subset of O365 customers
Incident Report for AppRiver
Resolved
We have resolved the delivery issue and have confirmed email delivery has resumed for those affected customers. We apologize for any inconvenience this may have caused.
Posted Jan 23, 2023 - 12:57 CST
Investigating
We are currently experiencing an issue which is affecting a subset of customers who have O365 as a mail hosting provider. We are working on resolving this issue currently. We apologize for any inconvenience this may be causing.
Posted Jan 23, 2023 - 11:12 CST
This incident affected: Email Security.