Customer Portal access
Incident Report for Zix | AppRiver
Resolved
We have confirmed the issue has been resolved and all traffic to our portal is working as expected. We apologize for any inconvenience this may have caused.
Posted Mar 28, 2023 - 11:49 CDT
Investigating
We are currently seeing issues with access to our Customer Portal. We are working on resolving as soon as possible. We apologize for any inconvenience this may be causing.
Posted Mar 28, 2023 - 10:11 CDT
This incident affected: Customer Portal Interface (Customer Portal).