Emails delays sending to @zixcorp.com addresses
Incident Report for Zix | AppRiver
Resolved
We have resolved this issue and normal email flow has been restored. We apologize for any inconvenience this may have caused.
Posted Mar 08, 2023 - 07:21 CST
Identified
We identified the issue with emails to the zixcorp.com and are engaging with Microsoft to resolve. For any current issues please email support@appriver.com or call us directly at 888-576-4949 for immediate assistance.
Posted Mar 07, 2023 - 15:49 CST
Investigating
We are currently investigating an issue with inbound email delivery to our zixcorp.com address. If you are needing to open a support case please email to support@appriver.com. We apologize for any inconvenience this may currently be causing.
Posted Mar 07, 2023 - 12:59 CST
This incident affected: Support Infrastructure (Support Ticketing System).