Exchange Online service alert MS Apps
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 06:56 CST
Update
We are continuing to investigate this issue.
Posted Nov 04, 2021 - 13:18 CDT
Investigating
Title: Some users may experience intermittent failures when accessing various My Apps functionality

IS296131, Identity Service

User impact: Users may experience intermittent failures when accessing various My Apps functionality.

More info: Users attempting to load My Apps functionality may experience failures or see errors when attempting the following functions:

-Single sign on applications
-Registering for multifactor authentication
-Self-service password reset
-Performing self-service management of groups
-Accepting terms of use agreements

As a viable workaround, user may refresh to alleviate the impact.

Current status: We've identified that a recent change intended to validate the Microsoft Authentication Library (MSAL) and Active Directory Authentication Library (ADAL) libraries unexpectedly resulted in a code regression. We've connected the service to an alternate Azure infrastructure that doesn’t have the recent change to potentially remediate impact.

Scope of impact: Your organization is affected by this event, and some users may experience intermittent failures when loading various My Apps functionality.

Start time: Wednesday, November 3, 2021, 10:20 AM (3:20 PM UTC)

Root cause: A recent change intended to validate the Microsoft Authentication Library (MSAL) and Active Directory Authentication Library (ADAL) libraries in Azure unexpectedly resulted in a code regression.

Next update by: Wednesday, November 3, 2021, 1:30 PM (6:30 PM UTC)
Posted Nov 03, 2021 - 12:38 CDT
This incident affected: Office 365.