Office 365 - Users may be unable to access mailboxes in Outlook on the web.
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Feb 20, 2021 - 13:59 CST
Investigating
EX240591, Exchange Online
Start time: February 19, 2021 4:09 PM

Title: Users may be unable to access mailboxes in Outlook on the web

User Impact: Users may be unable to access mailboxes in Outlook on the web.

Current status: We're analyzing internal data to determine the source of the issue.

Scope of impact: Any user may experience impact.

Next update by: Friday, February 19, 2021, at 11:30 PM UTC
Posted Feb 19, 2021 - 16:22 CST
This incident affected: Office 365.