SecureTide Email Delivery
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved. Email delivery has been restored for affected customers.
Posted Jun 20, 2018 - 03:18 CDT
Identified
We're experiencing an issue with mail delivery for some customers. We have identified the issue and service will be restored shortly.
Posted Jun 20, 2018 - 02:47 CDT
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)) and Threat Protection (Email Threat Protection).