Provider outage
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 30, 2018 - 18:03 CDT
Update
The situation seems to be improving for many regions, but we do have many customers still experiencing issues at this time.
Posted 5 months ago. Jun 29, 2018 - 13:52 CDT
Identified
We've been notified that Comcast and other providers are currently experiencing a significant outage. This could result in wide-spread Internet issues and may affect mail flow across those networks, as well as general connectivity issues. AppRiver is not experiencing any issues, however, customers may be affected by those provider outages even if they do not use them directly.
Posted 5 months ago. Jun 29, 2018 - 12:15 CDT