SecureSurf issue
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted about 2 months ago. Mar 26, 2018 - 12:16 CDT
Investigating
Our team is currently investigating a tag issue with SecureSurf. This may cause issues with Google services and other sites that should have this tag set. We will update this page once we have more information.
Posted about 2 months ago. Mar 26, 2018 - 09:11 CDT