Limited email delivery issues
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted 10 months ago. Oct 30, 2017 - 15:57 CDT
Investigating
A limited set of customers may be experiencing email delivery issues and may see latency when sending email. Our engineering team is working to resolve this issue.
Posted 10 months ago. Oct 30, 2017 - 15:22 CDT