Phone service interruption
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted over 1 year ago. May 05, 2017 - 03:43 CDT
Monitoring
AppRiver's toll-free phone line is operational now. For support, call 866-223-4645 or submit a ticket.
Posted over 1 year ago. May 05, 2017 - 02:07 CDT
Update
AppRiver's toll-free phone line is operational now. For support, call 866-223-4645.
Posted over 1 year ago. May 05, 2017 - 01:59 CDT
Identified
AppRiver is experiencing a temporary phone outage due to a fiber cut by our service provider. Callers may experience delays.
Posted over 1 year ago. May 05, 2017 - 00:42 CDT