Outbound mail delays
Incident Report for AppRiver LLC
Resolved
This issue has been resolved. Please call 1-866-223-4645 with any questions.
Posted 7 months ago. Jun 27, 2017 - 16:23 CDT
Investigating
As of 12:00 PM (CST) we began experiencing outbound mail processing delays in some data centers. Our team is currently investigating and working on a resolution for this issue. An update will be available once we have more information.
Posted 7 months ago. Jun 27, 2017 - 13:57 CDT