Customer Portal issue
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 10, 2018 - 08:43 CDT
Investigating
The Customer Portal is currently unable to display Hosted Exchange information for customers. The service bubble will show the service as active, but no further information is displayed within the users details. We will update this page once we have more information.
Posted 4 months ago. Aug 10, 2018 - 08:10 CDT
This incident affected: Customer Portals & User Interfaces (Customer Portal).