Customer Portal issue
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Nov 29, 2016 - 20:34 CST
Investigating
AppRiver is seeing an issue with a major Internet backbone provider, Level 3. This may impact routes for customers to access us, as well as slowness with the Customer Portal. This status will be updated once more information becomes available.
Posted Nov 29, 2016 - 17:00 CST