Customer Portal issue
Incident Report for AppRiver LLC
Resolved
The Customer Portal, including the Partner and Billing areas, is now operational.
Posted 27 days ago. Nov 14, 2018 - 11:57 CST
Investigating
We are aware of an issue with the Customer Portal, including the Partner and Billing areas and are working to resolve.
Posted 27 days ago. Nov 14, 2018 - 11:20 CST
This incident affected: Customer Portals & User Interfaces (Customer Portal, Partner Portal, Billing Area).