Phone System Down
Incident Report for AppRiver LLC
Resolved
Phone systems are back on line.
Posted 21 days ago. Oct 01, 2018 - 06:46 CDT
Identified
A power outage has caused AppRiver's phones to be temporarily unavailable. Customers may still reach our support team via email or chat.
Posted 21 days ago. Sep 30, 2018 - 20:32 CDT
This incident affected: Support Infrastructure (AppRiver Phone System).