Customer Portal issue
Incident Report for AppRiver LLC
Resolved
Our team has isolated and resolved this issue. The Customer Portal is now accessible.
Posted 4 months ago. May 15, 2018 - 15:40 CDT
Investigating
Our team is currently investigating an issue with the Customer Portal that is preventing login access for customers. We will update this page once we have more information.
Posted 4 months ago. May 15, 2018 - 15:23 CDT