ECS issue
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted over 1 year ago. Apr 19, 2017 - 13:01 CDT
Investigating
Our team is currently investigating an ECS issue which may prevent user admins from adding new users or accessing reporting in the portal. We will update this page once we have more information.
Posted over 1 year ago. Apr 19, 2017 - 12:52 CDT