Maintenance issue
Incident Report for AppRiver LLC
Resolved
Maintenance is now complete.
Posted 3 months ago. Aug 29, 2018 - 22:12 CDT
Update
Maintenance may result in delays for affected customers, but no mail loss is to be expected.
Posted 3 months ago. Aug 29, 2018 - 21:41 CDT
Identified
Our team is currently performing maintenance that may affect email and Customer Portal connectivity for some customers. We will update this page once the maintenance is complete.
Posted 3 months ago. Aug 29, 2018 - 21:18 CDT