Support Phone Issues
Incident Report for AppRiver LLC
Resolved
The intermittent phone issues have been resolved.
Posted about 1 year ago. May 21, 2017 - 02:11 CDT
Identified
Our support team is experiencing issues with incoming phone calls. We are working to address the issue.
Posted about 1 year ago. May 20, 2017 - 14:05 CDT