EXG7 connection issue
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Sep 22, 2016 - 00:41 CDT
Investigating
Our team is currently investigating a connection issue that may affect some EXG7 users on the West Coast. We will update this page as soon as we have more information.
Posted Sep 21, 2016 - 22:02 CDT