Email delays
Incident Report for Zix | AppRiver
Resolved
The email delay issue has been resolved.
Posted Sep 14, 2016 - 17:59 CDT
Identified
We have identified an issue in which some customers may be experiencing email latency. Our team is currently working on a resolution and we will provide an update shortly.
Posted Sep 14, 2016 - 13:17 CDT