Mail delays
Incident Report for AppRiver LLC
Resolved
This issue has been resolved and normal mail flow has resumed. All queued mail should be received shortly. We apologize for any inconvenience this may have caused.
Posted 2 months ago. Jul 09, 2018 - 13:01 CDT
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Jul 09, 2018 - 11:49 CDT
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Jul 09, 2018 - 11:48 CDT
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Jul 09, 2018 - 11:46 CDT
Update
The mail delays are due to a rescan of messages. The queue is currently processing and mail is flowing. Our team is working to clear the queue and deliver all mail as quickly as possible.
Posted 2 months ago. Jul 09, 2018 - 11:27 CDT
Identified
AppRiver is currently looking into an issue that is causing email delays to some of our customers' email platforms. These emails are not lost, but they are being held in queue until they can be delivered. Our team is working to resolve the issue as quickly as possible and we will provide an update as soon as we have one.
Posted 2 months ago. Jul 09, 2018 - 09:46 CDT
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7), Exchange 2010 (EXG6)) and SpamLab, Office 365.