SecureSurf Issue
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted 7 months ago. Sep 14, 2017 - 13:35 CDT
Investigating
Our team is currently investigating a SecureSurf issue that may affect web browsing for SecureSurf customers, as well as web protection functionality. We expect a quick resolution and this page will be updated once we have more information.
Posted 7 months ago. Sep 14, 2017 - 11:36 CDT