Mail Delivery Delays
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 12, 2018 - 16:32 CDT
Update
Our team is still monitoring a sporadic connection issue between AppRiver and some of our customers' servers. We have taken steps internally that have mitigated the problem substantially, but we are still investigating.
Posted 6 months ago. Jun 12, 2018 - 09:20 CDT
Update
AppRiver's engineers are monitoring what appears to be an issue with at least one of our backbone internet providers. Our team is working with several of them currently to isolate the source of our earlier mail delivery delays. At present, mail delivery has returned to normal, but we still want to know the source of the issue and ensure it is truly resolved.
Posted 6 months ago. Jun 11, 2018 - 16:51 CDT
Monitoring
AppRiver's engineers are monitoring what appears to be an issue with at least one of our backbone internet providers. Our team is working with several of them currently to isolate the source of our earlier mail delivery delays. At present, mail delivery has returned to normal, but we still want to know the source of the issue and ensure it is truly resolved.
Posted 6 months ago. Jun 11, 2018 - 16:50 CDT
Investigating
AppRiver is currently looking into an issue that is preventing our servers from delivering mail to some of our customers' email platforms. These emails are not lost, but they are being held in queue until they can be delivered. Our team is working to resolve the problem as quickly as possible and we will update you when we know more or we have fixed the issue.
Posted 6 months ago. Jun 11, 2018 - 11:54 CDT