Global Relay Orders
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted 10 months ago. Sep 08, 2017 - 13:00 CDT
Identified
The issue has been identified and our team is currently working on a resolution that should be released some time today. This page will be updated once the resolution is in place.
Posted 10 months ago. Sep 08, 2017 - 09:10 CDT
Investigating
Our team is currently investigating an issue with the Customer Portal that is resulting in partners not being able to place Global Relay orders from the Partner Area. if you need to place a Global Relay order, our Sales team is able to do so for you at 866-223-4645. We apologize for the inconvenience and this page will be updated once we have more information.
Posted 10 months ago. Sep 07, 2017 - 15:20 CDT