CipherPost Pro® issue
Incident Report for AppRiver LLC
Resolved
This incident has been resolved, however, our team is still working to ensure all users are back up.
Posted 11 months ago. Mar 20, 2018 - 15:04 CDT
Investigating
Our team is currently investigating a CipherPost Pro issue that may prevent some CPP users from being able to send or access secure messages. This page will be updated once we have more information.
Posted 11 months ago. Mar 20, 2018 - 13:26 CDT