Mail delivery issue
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 09, 2018 - 13:16 CST
Update
Users can expect possible mail delays as our team continues to investigate.
Posted 4 months ago. Feb 09, 2018 - 12:23 CST
Investigating
Our team is currently investigating an issue with one of our delivery servers that is causing some mail to bounce. We will update this page once we have more information.
Posted 4 months ago. Feb 09, 2018 - 11:56 CST