Held Spam Reports Not Delivered Yesterday
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted 7 months ago. May 23, 2018 - 13:15 CDT
Identified
Some AppRiver customers did not receive held spam reports yesterday due to a configuration issue in a recent software update. Our team has identified and corrected the problem and customers will receive today's report that will include held spam that came in yesterday.
Posted 7 months ago. May 23, 2018 - 07:51 CDT