Customer Portal and Supportal issue
Incident Report for Zix | AppRiver
Resolved
The issue has been resolved, however, we are still investigating the root cause.
Posted Dec 09, 2016 - 09:56 CST
Investigating
Our team is currently investigating an issue causing slow performance and login failures with the Customer Portal. We are experiencing high call volumes as a result. This page will be updated once more information becomes available.
Posted Dec 09, 2016 - 08:30 CST