Customer Portal Issues
Incident Report for AppRiver LLC
Resolved
AppRiver's team has resolved the issue causing some customers to receive an error message when logging in to the Customer Portal.
Posted 9 months ago. Jan 10, 2018 - 15:33 CST
Investigating
Some customers are reporting an error message when logging in to the AppRiver Customer Portal. Our team is investigating and we will update when we have more information or the problem is resolved.
Posted 9 months ago. Jan 10, 2018 - 14:38 CST