CipherPost Pro issue
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 16, 2018 - 13:50 CST
Investigating
We have received reports that some CipherPost Pro users are unable to create secure messages via their Outlook client. Our team is investigating this issue and we will update this page when we have more information.
Posted 6 months ago. Jan 16, 2018 - 10:35 CST