European mail delays and SecureSurf issue
Incident Report for AppRiver LLC
Resolved
The issue has been resolved and traffic flow has returned to normal. Customers may have experienced delays and SecureSurf disruption from 3:15 p.m. until 4:15 p.m. GMT+1.
Posted 11 months ago. Aug 23, 2017 - 10:35 CDT
Investigating
Our team is currently investigating an issue with our London data center that may result in mail delays for AppRiver customers sending mail within Europe, as well as for those sending mail to and from European customers. SecureSurf customers may also notice a disruption to their service. This page will be updated once we have more information.
Posted 11 months ago. Aug 23, 2017 - 10:09 CDT